About Us  Contact  Legal  Accessibility Topologi
Topologi FAQ

Q1. Can the validator run from a command line?

Neither the Topologi Schematron Validator (TSV) nor the Topologi Collaborative Markup Editor (TCME) can validate from the command line. However, Topologi does provide Eddie Robertsson's Open Source validator which can run from a command line: like other Topologi products, it supports DTDs, Schematron, W3C XML Schemas (WXS) and RELAX NG, plus Schematron embedded in WXS or RELAX NG. (Unix and Mac OS X users: you can convert the .bat file to a shell script trivially.)

See http://www.topologi.com/resources/Schematron.zip.

Also note that most other Schematron implementations also allow command line use. See schematron.com for more information on Schematron.

Q2. When I validate with W3C XML Schema (WXS) in product X it gives a different result: is your implementation broken?

Due to the complexity of WXS, many implementations give different results, especially for the "fringe" cases. At the current state of implementations, it is prudent to avoid "fringe" features where possible and to validate using multiple validators. For example, validate using product X but also validate using TSV or TCME.

The TCME uses a customized version of the Apache Xerces (2.2.1) library for WXS validation. The TSV uses Microsoft's MSXML library.

Q3. How do I create templates in the TCME?

Templates (and other SideBar settings) are loaded from a Named Information Item (NII) file. The NII format is documented at http://www.topologi.com/resources/pdfs/NamedInformationItems.pdf.

Templates (and schemas and stylesheets) will typically be loaded in an XML Application Archive (XAR) file. The XAR format is ZIP plus some conventions, and is documented at http://www.topologi.com/products/validator/dzip.html.

Q4. How do I create my own XAR file for TCME?

1. Select File>New>New Document>XML to start with a clean slate.

2. Then select Validation>Set up Schemas to bring up the Document Type Information box.

3. Then use the "Browse" button to select the various files you need, for each tab.

4. Finally, press "Create" to create a new XAR with these files.

5. Specify "Local" if you want the XAR just for yourself, or "Peers" if you want the XAR to also go to others in your workgroup.

Note that this creation process is not smart enough to look inside files and see which files they in turn require. So if you have a schema which includes some other schema, it is best to keep it all in one file if possible.

If you must keep multiple files, you can simply open the file in the editor, then use Tools>Export>Export to ZIP, and then select TCME/schemas/local/xxxx.dz2 where "TCME" is the distribution directory for the editor, and "xxx" is the file you just created. Please note the naming conventions in the XAR specification: you cannot have multiple .dtd etc files at the top-level of the XAR.

To include non-text files such as icons, use some ZIP package, such as WinZip.

Q5. When installing the Topologi Schematron Validator I get an error message

This is almost always because you have not installed MSXML 4 first.

Q6. How can I specify which version of Java the editor should use?

The editor can run using a private JRE installed in TCME/jre/ or using the environment's JRE. The Windows version of the editor comes with a Java runtime that is used by default; the Linux and Mac OS X versions use the environment's Java Runtime Environment (JRE).

On Windows, to change to use a different private JRE just delete the current TCME/jre directory and copy the JRE you want to that location. If you want to use an existing installation, then you must use the .bat file instead of the .exe files. You must check that the -distributionDir command line parameter is set correctly if you don't wish to use a private JRE.

On Linux, to change to use a different private JRE just copy the JRE you want to TCME/jre and use the shell script provided.

(On Mac OS X, please check Apple's documentation. Probably you would have to enter the Topologi application and change some value in a property list.)

Q7. I installed the editor but it is acting strangely and I cannot quit.

This may occur in three situations:

A. The editor has been installed by one user, and you do not have the appropriate permissions to write to log files etc.

B. You are using a system-provided JRE and the -distributionDir option in the shell or command line files is not correct.

C. You are using the Mac OS X version, and have installed the editor somewhere other than the default setting (the System drive, in /Applications/ ). You will need to browse the application Topologi and change the appropriate property list, as specified in the installation screens.

Q8. Can I run the editor from a central distribution to multiple users?

No. The editor has not been designed for this: for example, the peer-to-peer facility requires individual access to directories. Every user should get their own complete distribution installed. This is increasingly common practise for Java systems, because of the need to guarantee that a particular version of the JRE is used.

However, please note that the editor does not write to the following directories in the distribution: TCME/bin, TCME/jar, TCME/jre, TCME/lib and consequently these can be shared between users to minimize space, e.g. using a symbolic link under Unix.

Q9. When running the editor under Linux, I get error messages about Audio Drivers not being installed. What is this?

Recent versions of the editor should not have this problem. Shrink-wrapped versions of Linux often come with audio drivers built-in; if these do not match your system, it can cause spurious errors. Select Edit>Options...>Editor>Audio to disable audio cues.

Q10. When I have 100 other applications open, then the Topologi editor seems slows; I am running under Windows 98. What is wrong?

Java applications in general do not seem to run well on overloaded Windows 98 systems; Java applications tend to expand to as much (heap) memory as they have been allocated and this does not seem to sit well with Win98 memory management when there are multiple systems. We do not list Windows 98 in the operating systems we support, however we do test the editor on Windows 98.

Possible workarounds: stop the editor's peer-to-peer networking; minimise the window when not using the editor, increase the Virtual memory allocation.

(Another issue in Windows 98 is that cut-and-paste from some applications may not operate correctly if the text has certain extended characters. Also, many fonts used on Windows 98 systems have incorrect font metrics, which may occassionally cause display slow-downs.)

Q11. I have a 100 Meg document. Can your editor handle it?

As of version 1.1.6, the editor can handle large files. The size of files is primarily limited in the editor by the memory available: see Editing the Million-Line XML Documents for details.

Q12. I am trying to make an XAR file with Winzip and a) it is not visible in the Validation>Setup the default schemas box or b) I cannot see the DTD.

For a) the two usual causes are either that the XAR does not have a name that follows the naming rules (must end in "-nn.dz2" where nn is a version number, and where "_" is used instead of spaces) or that it is not in the correct directory (should be under a subdirectory of the xar/ directory, such as C:\Program Files\topologi\tme1.1\xar\local\My_Schemas-01.dz2.

(And you may have to restart Topologi if you change the XAR while Topologi is running.)

For b) the usual reason is that your XAR has two files with the .dtd extension. There can only be one XML DTD per XAR at the top-level: if your DTD has subordinate files then rename them with a different extension or put them in a subdirectory. The same thing holds true for the other schemas and stylesheets in an XAR.

 

  Copyright 2002-04 Topologi Pty. Ltd. ABN 74 096 635 102 Webmaster